IUG FORUM

Stay always connected!
  1. Phil Shirley
  2. Sierra/ Millennium/ Encore
  3. Wednesday, 22 January 2020
  4.  Subscribe via email
We have a print template for a spine label that worked in Windows 7 that does not work in Windows 10. Jaspersoft studio shows no errors, but when you try to preview it in Sierra you get "failed to preview template." If I do one bit at a time, it works until I paste in the expression below. Can anyone tell me why? Is there something wrong with this expression?

(($F{itemFix79}.equals("auto ";) || $F{itemFix79}.equals("moto ";) ? $F{callEntire}.replaceAll(" ","\n";) :
($F{itemFix79}.startsWith("dvd";) ? $F{callEntire}.replace("Season ", "Season \n";).replace(" Disc ", "\nDisc\n";) :
(!$F{callEntire}.equals("";) ? $F{callEntire}.replaceAll("\\.","\n\\.";) : "";)))
+
(!$F{itemv}.equals("";) ? ("\n" + $F{itemv}): "";))

pshirley@cuyahogafallslibrary.org

derek.brown@rhpl.org
Phil Shirley
Technology Services Coordinator
Cuyahoga Falls Library
Comment
There are no comments made yet.
Accepted Answer
Accepted Answer Pending Moderation
0
Votes
Undo
In your dvd phrase - you have to use .replaceFirst or .replaceAll instead of just .replace

pskittino@deerfieldlibrary.org
Comment
There are no comments made yet.
Accepted Answer Pending Moderation
0
Votes
Undo
Thanks, Pam -- that fixed it.

pshirley@cuyahogafallslibrary.org
Phil Shirley
Technology Services Coordinator
Cuyahoga Falls Library
Comment
There are no comments made yet.
  1. more than a month ago
  2. Sierra/ Millennium/ Encore
  3. # 1
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!