IUG FORUM

Stay always connected!
  1. Brenda Carrillo
  2. Sierra/ Millennium/ Encore
  3. Wednesday, 04 October 2017
  4.  Subscribe via email

Hello, we are trying unsuccessfully to implement the GOBI API. We have had no luck. Does anyone have any ideas of where we could possibly look for answers (beside the Sierra API documentation). We had Innovative make changes to our API load table (made it match to Santa Clara's poster session notes (thank you for trying to help!), and we have tried trouble shooting with GOBI to no end.

The error that comes back is (in Gobi's terms "generic") it is:

Error Code: 115
Error Name: Invalid JSON
Error Description: JSON object missing field or field has invalid data

Any thoughts out there?

 

Thanks,

Brenda Carrillo

University of the Pacific - Stockton



bcarrillo@pacific.edu
Comment
  1. Guest
  2. 2 years ago
  3. #920
Thank you I sent you an email!
  1. Guest
  2. 2 years ago
  3. #919
Hi Brenda,

Did the bib records get loaded into Sierra at all? Have you check the error log to see what might need to be corrected? Sometimes the m2btab.b load profile needs to be adjusted. Sometimes re-sending the API Key to GOBI can do the trick. We at SCU haven't seen the kind of errors you encountered. if it's of any help to brainstorm, you are welcome to email me offline (wlu@scu.edu).

Wen-ying Lu
Santa Clara University Library
There are no comments made yet.
Accepted Answer Pending Moderation
0
Votes
Undo

Have YBP send you a copy of the JSON file.

Is anything appearing in the Data Exchange menu item (which you may have to have III enable [ https://sandbox.iii.com/docs/Content/zReference/errorHandling.htm?Highlight=115 ])?

Do you have shell access? If so, the log files on the app server are:

/iiidb/catbase-public2/logs/sierra-api.log
/iiidb/catbase-public2/logs/sierra-api-marc2inn.log

HTH,
David



djones@scu.edu
Comment
There are no comments made yet.
  1. more than a month ago
  2. Sierra/ Millennium/ Encore
  3. # 1
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!